ControlSpace Designer Introduction

Applies to:

  • ControlSpace Designer software
  • ControlSpace EX-1280C

When ControlSpace® Designer is first opened, most of the screen is occupied by a tab labeled, “Project View”. On the left side of the screen is a docked window labeled, “Device List”. Add virtual devices to the design by dragging devices from the Device List and dropping them into the Project View.

Tabs – ControlSpace Designer will always have a Project View tab. When a sound processor or PowerMatch® amplifier is added to the Project View, a new Design View tab will be created for each device. Selecting one of these Design View tabs will display the current programming for that sound processor or amplifier, and will allow editing of the programming for that device. Design View tabs can also be accessed by double-clicking the appropriate device in the Project View.
 

Design View tabs are not created for Dante Endpoints, Control Centers, or non-programmable devices. These types of devices are programmed using the individual device control panels.

Device List
– The Device List on the left side of the screen contains six expandable categories of devices.

•   Sound Processors – All current, programmable digital signal processors.
•   PowerMatch Amplifiers – All current, programmable PowerMatch amplifiers. This category is divided into two subcategories of Networked (Ethernet-enabled) amps and USB (non-Ethernet) amps.
•   Dante Endpoints – Under-table Dante endpoints, Dante wall plates, and Dante-enabled microphones that can be directly controlled by ControlSpace Designer.
•   Control Centers – All wall controls.
•   Discontinued – Devices that are out of production but can still be programmed and controlled by ControlSpace Designer.
•   Devices – This category contains devices that are not programmable by ControlSpace Designer but may be added to the design file to better illustrate the system.

With a few exceptions, these devices can be programmed directly from ControlSpace Designer after being placed in the Project View. The non-programmable devices are the CC-1, CC-2, CC-3, and everything in the "Devices” category. These are all representational devices which are added to the Project View to provide an illustration of the system layout. For the CC-1, CC-2, and CC-3, the device is physically wired to GPIO ports on the DSP and the GPIO ports are then programmed for the appropriate functionality. The Devices category contains items that are intended to be placed in the Project View as an illustration of system functionality. Placing an item from the Devices category into the Project View has no effect on the functionality of the system.

Wiring – There’s only one type of wiring in the Project View that has a functional purpose. When using a programmable wall controller, the wall controller must be assigned to one DSP in the system. The wall controller may be programmed to control parameters from multiple devices, but the assigned DSP serves as a gateway to the system and maintains the programming for the wall controller. This assignment is created by wiring from the wall controller to the assigned DSP device. The wiring between the wall controller and the DSP will appear as a green line in the Project View to indicate that the assignment has been made. All other wiring in the Project View will appear as black lines to indicate that this wiring is purely representational and has no effect on the functionality of the system.

Output Nodes – Each output node on a DSP or amplifier in the Project View will be represented by one of three icons. Each of these icons represents a different state for the output.

  • X – Indicates that there is no signal path wired to that output node. There’s no possibility of audio being sent to that output node.
  • Red Triangle – Indicates that there is a signal path wired to that output node; audio can be sent to that output but the output is currently muted.
  • Open Triangle – Indicates that there is a signal path wired to that output node; audio can be sent to that output and the output is unmuted.

Menus
File Menu – In addition to standard Windows tools, the File menu includes

•   Merge Projects – Used to merge a second ControlSpace Designer project file into the currently open project file.
•   Project Information – Provides access to the Project Information panel where data fields are used to store contact information and notes relevant to this project.

Edit Menu – In addition to standard Windows tools, the Edit menu includes

•   Copy Parameters – Copies all parameters of the currently selected object to the clipboard.
•   Paste Parameters – Pastes all parameters from the clipboard to the currently selected object(s). This option will be unavailable when the clipboard is empty, when there is currently no object selected, or when the selected object doesn’t match the object that was copied to the clipboard. This function allows parameters to be simultaneously pasted to multiple objects of the same type if the objects have all been selected.
•   Align – Various alignment options allow multiple devices or objects to be visually aligned on the screen.

View Menu – In addition to standard Windows tools, the View menu includes

•   Show Grid – Switches the background grid in Project View or Device View between multiple grid patterns or no grid.
•   Hide/Show All Logic I/O – Toggles the display of Logic programming nodes on all objects in Device View.
•   Hide/Show Signal Processing Logic – Toggle the display of Logic programming nodes on signal processing objects only.
•   Hide/Show All Wires – Toggles the display of all wiring.
•   Hide/Show Audio Wires – Toggles the display of audio wiring.
•   Hide/Show Logic Wires – Toggles the display of logic wiring.
•   System Status – Displays the monitor panels for all PowerMatch amplifiers in the project.
•   System Status Settings – Controls the layout for displayed PowerMatch status panels.
•   Wire Style – Selects the automatic line style to be used in the project: line, orthogonal, or Bezier.
•   Wire Colors – Assigns the default wire color for audio, logic, and network wires.
•   Show Wiring Crosshair – Toggles the display of full screen crosshairs when wiring.
•   Overview – Toggles the display of the bird’s-eye overview window.

Tools Menu – The Tools menu includes

•   Set Temperature – Opens the temperature window to set the temperature for which you would like to calculate delay times when entering feet/meters to set delay times.
•   Set Main DSP – Specifies which device is the real-time clock for the system.
•   DSP Resources – Provides access to the processing and delay memory usage data for the currently selected DSP.
•   Set Project Network Properties – Opens the Project Network Properties window to allow assignment of project network settings.
•   Set File Password – Opens the File Password dialog to allow the current file, and any system programmed with the current file, to be password protected.
•   Add Note – Places an editable note object in the currently selected view.
•   System Mute – Toggles the master mute state of all system devices. This functionality only exists while online to the system.
•   Toggle Standby – Toggles the standby state of all connected devices that support a Standby mode.
•   Scan – Detects hardware on the local network and adds virtual representations of that hardware to a new file.
•   Go Online/Offline – Connects to or disconnects from attached devices.

System Menu – The System menu includes

•   Host NIC Setup – Allows the assignment of a specific NIC for use by ControlSpace Designer.
•   Hardware Manager – Opens the Hardware Manager window.
•   Enable/Disable Remote Connection – Provides access to the Remote Network Connection dialog for connecting ControlSpace Designer to devices on a different subnet.
•   Enable/Disable Dante Control – Determines whether Dante Properties are controlled by ControlSpace Designer or by other software (Dante Controller).
•   Dante Properties – Opens the Dante Properties dialog. Only available when Dante Control by ControlSpace Designer is enabled.
•   Enable Dynamic Routing – Enables Dante Dynamic Routing.
•   Retrieve Saved Design – Retrieves the saved design from a network device (without attempting to Go Online to the device) and opens the design in ControlSpace Designer.
•   Save Retrieved Design to File – Retrieves the saved design from a network device (without attempting to Go Online to the device) and saves the retrieved design as a file.

Window Menu – The Window menu includes

•   Device List – Toggles the display of the Device List window.
•   Project Directory – Toggles the display of the Project Directory window.
•   Properties – Toggles the display of the Properties window.
•   Parameter Sets – Toggles the display of the Parameter Sets window.
•   Groups – Toggles the display of the Groups window.
•   RCGroups – Toggles the display of the RCGroups window.
•   Timers – Toggles the display of the Timers window.
•   Hide All – Removes all windows.
•   Load to default positions – Opens all default windows and resets all window positions to their default values.